Переполнение буфера в XnView и NConvert

Дата публикации:
30.01.2008
Всего просмотров:
1644
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NConvert 4.x
XnView 1.x
Уязвимые версии:
XnView 1.92, и более ранние версии
NConvert 4.85, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке Radiance RGBE (*.hdr) файлов. Удаленный пользователь может с помощью специально сформированного Radiance RGBE файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.xnview.com

Решение: Установите последнюю версию XnView 1.92.1 и NConvert 4.86 с сайта производителя.

Ссылки: Secunia Research: XnView, NConvert, and GFL SDK Radiance RGBE Buffer Overflow

или введите имя

CAPTCHA