PHP-инклюдинг в Connectix Boards

Дата публикации:
30.01.2008
Всего просмотров:
933
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Connectix Boards 0.x
Уязвимые версии: Connectix Boards 0.8.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "template_path" в сценарии templates/Official/part_userprofile.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.connectix-boards.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Connectix Boards <= 0.8.2 template_path Remote File Inclusion Exploit

или введите имя

CAPTCHA