Множественные уязвимости в Coppermine Photo Gallery

Дата публикации:
30.01.2008
Дата изменения:
14.04.2008
Всего просмотров:
1982
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0504
CVE-2008-0505
CVE-2008-0506
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Coppermine Photo Gallery 1.x
Уязвимые версии: Coppermine Photo Gallery версии до 1.4.15

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценариях util.php и reviewcom.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии include/imageObjectIM.class.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные команды на системе. Для удачной эксплуатации уязвимости требуются валидные учетные данные.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "h" и "t" в сценарии docs/showdoc.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: coppermine-gallery.net

Решение: Установите последнюю версию 1.4.15 с сайта производителя.

или введите имя

CAPTCHA