Переполнение буфера в Firebird

Дата публикации:
28.01.2008
Дата изменения:
21.05.2008
Всего просмотров:
1600
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0387
CVE-2008-0467
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Firebird 1.x
Firebird 2.x
Уязвимые версии: Firebird версии 2.1 Beta 2, 2.0.3, 2.0.2, 2.0.0, 1.0.3, 2.1 Beta 1, 2.1 Alpha 1, 2.0.1 и 1.5.4

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке имен пользователей. Удаленный пользователь может с помощью слишком длинного имени пользователя вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки при обработке сетевых пакетов. Удаленный пользователь может с помощью специально сформированного пакета вызвать отказ в обслуживании приложения.

URL производителя: www.firebirdsql.org

Решение: Установите последнюю версию 2.0.4 с сайта производителя.

Журнал изменений:

31.01.2008
Добавлен PoC код. 05.03.2008
Добавлена уязвимость #2.
21.05.2008
Изменена секция «Решение».

Ссылки: Firebird < 2.1 RC1 Remote Denail of Service PoC
Firebird Remote Memory Corruption

или введите имя

CAPTCHA