Межсайтовый скриптинг в PacerCMS

Дата публикации:
22.01.2008
Дата изменения:
23.01.2008
Всего просмотров:
971
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0451
CVE-2008-0426
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PacerCMS 0.x
Уязвимые версии: PacerCMS версии до 0.6.1, возможно более ранние

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных параметрах в сценарии submit.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценариях siteadmin/article-edit.php, siteadmin/submitted-edit.php, siteadmin/page-edit.php, siteadmin/section-edit.php, siteadmin/staff-edit.php и siteadmin/staff-access.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: pacercms.sourceforge.net

Решение: Установите последнюю версию 0.6.1 с сайта производителя.

Журнал изменений:

23.01.2008
Добавлено описание уязвимости #2

или введите имя

CAPTCHA