Несколько уязвимостей в MyBB

Дата публикации:
22.01.2008
Всего просмотров:
1229
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0787
CVE-2008-0788
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyBB (formerly MyBulletinBoard) 1.x
Уязвимые версии: MyBB 1.2.11, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии inc/datahandlers/pm.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может удалить произвольные ветки форума с привилегиями модератора, посетившего злонамеренный сайт.

URL производителя: www.mybboard.net

Решение: Установите последнюю версию 1.2.12 с сайта производителя.

или введите имя

CAPTCHA