Несколько уязвимостей в bloofoxCMS

Дата публикации:
22.01.2008
Дата изменения:
31.12.2008
Всего просмотров:
896
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0427
CVE-2008-0428
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
bloofoxCMS 0.x
Уязвимые версии: bloofoxCMS 0.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "username" в сценарии admin/index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "file" в сценарии file.php. Удаленный пользователь может с помощью специально сформированного HTTP заголовка "Referer", содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя: www.bloofox.com

Решение: Установите последнюю версию 0.3.1 с сайта производителя.

Журнал изменений:
07.04.2008
Изменена секция "Решение".

или введите имя

CAPTCHA