Несколько уязвимостей в Clever Copy

Дата публикации:
22.01.2008
Дата изменения:
28.04.2008
Всего просмотров:
1050
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0362
CVE-2008-0363
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Clever Copy 3.x
Уязвимые версии: Clever Copy 3.0 с security fix 1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ID" в сценариях postcomment.php и postview.php, и в параметре "album" в сценарии gallery.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "album" в сценарии gallery.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: clevercopy.bestdirectbuy.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

28.04.2008
Добавлен PoC код.

Ссылки: Clever Copy 3.0 (postview.php) Remote SQL Injection Exploit

или введите имя

CAPTCHA