PHP-инклюдинг в Mini File Host

Дата публикации:
21.01.2008
Дата изменения:
07.04.2008
Всего просмотров:
1681
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Mini File Host 1.x
Уязвимые версии: Mini File Host 1.2.1 и другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в сценарии pages/upload.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена и опция "magic_quotes_gpc" отключена в конфигурационном файле PHP.

URL производителя: galaxyscripts.com/forum/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


07.04.2008
Изменена секция "Решение".

Ссылки: Mini File Host 1.2.1 (upload.php language) Local File Inclusion Exploit

или введите имя

CAPTCHA