Межсайтовый скриптинг в BugTracker.NET

Дата публикации:
21.01.2008
Всего просмотров:
1104
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0335
CVE-2008-0336
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BugTracker.NET 2.x
Уязвимые версии: BugTracker.NET версии до 2.7.2

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных полях форм. Удаленный пользователь может с помощью специально сформированного запроса внедрить произвольный код сценария в страницу описания бреши и выполнить сценарий при просмотре бреши в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может произвести CSRF атаку и выполнить некоторые действия в приложении (например, удалить сообщения об ошибках) с привилегиями пользователя, посетившего специально сформированный сайт.

URL производителя: btnet.sourceforge.net/bugtrackernet.html

Решение: Установите последнюю версию 2.7.2 с сайта производителя.

или введите имя

CAPTCHA