Межсайтовый скриптинг в Adobe Dreamweaver/Contribute

Дата публикации:
18.01.2008
Всего просмотров:
1713
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-6244
CVE-2007-6637
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Adobe Contribute 4.x
Adobe Contribute CS3
Adobe Dreamweaver CS3
Macromedia Dreamweaver 8.x
Уязвимые версии:
Adobe Contribute 4
Adobe Contribute CS3
Adobe Dreamweaver CS3
Macromedia Dreamweaver 8

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных во время генерации кода с использованием команды "Insert Flash Video". Удаленный пользователь может с помощью специально сформированного SWF файла выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.adobe.com

Решение: Установите исправление с сайта производителя.

Обновите файлы FLVPlayer_Progressive.swf и FLVPlayer_Streaming.swf.
http://www.adobe.com/go/kb402925

Ссылки: Update to Dreamweaver and Contribute to address potential cross-site scripting vulnerabilities

или введите имя

CAPTCHA
20-01-2008 20:28:45
На сайте производителя доступно только исправлени "якобы" для версии 9. Мол остальные более не существуют. А ссылка на описание проблемы - Security Bulletin APSD08-01 просто у них не работает. Баг репорт им отправил. Надеюсь ошибку поправят, и мы узнаем как и в остальных версиях предлагают исправить проблему. А пока вижу единственный способ - поиск в файл менеджере, и замена некондиционных компонент. Естественно с предварительным резервированием. Иного решения предложить не могу.
0 |