Множественные уязвимости в Drupal

Дата публикации:
18.01.2008
Всего просмотров:
2515
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-0272
CVE-2008-0273
CVE-2008-0274
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 4.x
Drupal 5.x
Уязвимые версии: Drupal версии до 4.7.11 и 5.6

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в теме .tpl.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуется, чтобы опция "register_globals" была включена в конфигурационном файле PHP.

2. Уязвимость существует из-за ошибки в функционале фильтрации текста. Удаленный пользователь может с помощью некорректных UTF-8 последовательностей обойти фильтр и выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за того, что модуль aggregator позволяет пользователям произвести некоторые действия без проверки подлинности HTTP GET запроса. Злоумышленник может с помощью специально сформированного Web сайта удалить элементы из определенного информационного канала.

URL производителя: drupal.org

Решение: Установите последнюю версию 4.7.11 или 5.6 с сайта производителя.

или введите имя

CAPTCHA