PHP-инклюдинг в SAM Broadcaster

Дата публикации:
15.01.2008
Дата изменения:
15.01.2008
Всего просмотров:
2352
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAM Broadcaster 4.x
Уязвимые версии: SAM Broadcaster 4.3.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "commonpath" в сценарии common/db.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/common/db.php?commonpath=[file]

URL производителя: www.spacialaudio.com/products/sambroadcaster/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA