SQL-инъекция в Apache::AuthCAS

Дата публикации:
30.12.2007
Дата изменения:
25.03.2008
Всего просмотров:
1989
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache::AuthCAS 0.x
Уязвимые версии: Apache::AuthCAS 0.4, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре SESSION_COOKIE_NAME в файле куки в модуле lib/Apache/AuthCAS.pm. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: search.cpan.org/~dcastro/Apache-AuthCAS-0.4/lib/Apache/AuthCAS.pm

Решение: Установите последнюю версию 0.5 с сайта производителя.

Журнал изменений:

25.03.2008
Изменена секция «Решение».

или введите имя

CAPTCHA