Несколько уязвимостей в FAQMasterFlexPlus

Дата публикации:
29.12.2007
Дата изменения:
24.03.2009
Всего просмотров:
1046
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-6633
CVE-2007-6634
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FAQMasterFlexPlus 1.x
Уязвимые версии: FAQMasterFlexPlus 1.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "cat_name" в сценарии faq.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/faq.php?category_id=1&cat_name=[XSS]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "category_id" в сценарии faq.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для удачной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP. Пример:

http://[host]/faq.php?category_id=1'%20union%20select%201,1,user(),1/*

URL производителя: www.netbizcity.com/Downloads/tabid/65/rrcid/13/rrscid/0/rreid/103/rrpid/1/rrepp/5/Default.aspx

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA