PHP-инклюдинг в KML share

Дата публикации:
27.12.2007
Дата изменения:
10.04.2009
Всего просмотров:
900
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
KML share 1.x
Уязвимые версии: KML share 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "layer" в сценарии region.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/region.php?layer=[file]

URL производителя: sourceforge.net/projects/kmlshare/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA