Переполнение буфера в PDFlib

Дата публикации:
25.12.2007
Всего просмотров:
1044
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PDFlib 7.x
Уязвимые версии: PDFlib 7.0.2 для Linux на IA-32, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "pdc_fsearch_fopen()". Удаленный пользователь может передать функции "PDF_load_image()" слишком длинное имя файла в качестве параметра, вызвать переполнение стека и выполнить произвольный код на целевой системе. Пример:

<?php
.....
PDF_load_image($p,"jpeg",str_repeat("A",1100), null);
?>

URL производителя: www.pdflib.com/products/pdflib-family/pdflib/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA