Переполнение буфера в Zoom Player

Дата публикации:
25.12.2007
Всего просмотров:
1062
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Zoom Player 5.x
Уязвимые версии: Zoom Player 5.0.0.0, 6.00 beta 2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при создании сообщения об ошибке для файлов, которые невозможно проиграть. Удаленный пользователь может вызвать переполнение буфера с помощью специально сформированного ZPL фалйа, содержащего HTTP ссылку на файл, со слишком длинным именем и расширением PLS, и выполнить произвольный код на целевой системе. Пример:

	[zoomprayer.zpl]
	nm=http://127.0.0.1/AAAA[…]AAA.pls
	dr=0
	br!

URL производителя: inmatrix.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA