Переполнение буфера в WFTPD Explorer

Дата публикации:
24.12.2007
Всего просмотров:
850
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WFTPD Explorer
Уязвимые версии: WFTPD Explorer 1.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке ответов сервера на команду LIST. Злоумышленник, контролирующий FTP сервер, может с помощью слишком длинного ответа вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.wftpd.com/fcl.htm

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: WFTPD Explorer Pro 1.0 Remote Heap Overflow PoC

или введите имя

CAPTCHA