Переполнение буфера в CUPS SNMP Backend

Дата публикации:
19.12.2007
Всего просмотров:
1196
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Common Unix Printing System (CUPS) 1.x
Уязвимые версии: CUPS версии до 1.3.5

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки при обработке знаковых переменных в функции "asn1_get_string()" в файле backend/snmp.c. Удаленный пользователь может с помощью специально сформированного SNMP ответа, содержащего ASN1 кодированные строки, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.cups.org

Решение: Установите последнюю версию 1.3.5 с сайта производителя.

или введите имя

CAPTCHA