Переполнение буфера в PeerCast

Дата публикации:
19.12.2007
Дата изменения:
30.04.2008
Всего просмотров:
867
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PeerCast 0.x
Уязвимые версии: PeerCast 0.1217, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "handshakeHTTP()". Удаленный пользователь может с помощью специально сформированного "SOURCE" HTTP запроса вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.peercast.org

Решение: Установите последнюю версию 0.1218 с сайта производителя.

Ссылки: PeerCast Remote Heap Overflow PoC

или введите имя

CAPTCHA