Межсайтовый скриптинг в Ganglia

Дата публикации:
17.12.2007
Дата изменения:
30.01.2009
Всего просмотров:
870
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ganglia 3.x
Уязвимые версии: Ganglia версии до 3.0.6

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "c" и "h" в сценарии web/host_gmetrics.php, в параметрах "G", "me", "x", "n", "v", "l", "vl" и "st" в сценарии web/graph.php и в параметрах "c", "G", "h", "r", "m", "s", "cr", "hc", "sh", "p", "t", "jr", "js", "gw", "z" и "gs" в сценарии web/get_context.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.ganglia.info

Решение: Установите последнюю версию 3.0.6 с сайта производителя.

Ссылки: http://sourceforge.net/project/shownotes.php?release_id=562168

или введите имя

CAPTCHA