Межсайтовый скриптинг в Flyspray

Дата публикации:
17.12.2007
Всего просмотров:
787
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Flyspray 0.x
Уязвимые версии: Flyspray версии до 0.9.9.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "$_SERVER['QUERY_STRING']" в функции "savesearch()" и в параметре "details" в функции "getHistory()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: flyspray.org

Решение: Установите последнюю версию 0.9.9.4 с сайта производителя.

или введите имя

CAPTCHA