EJBQL-инъекция в JBoss Seam

Дата публикации:
13.12.2007
Всего просмотров:
1083
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
JBoss Seam 1.x
Уязвимые версии: JBoss Seam версии до 2.0.0.GA.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "order" в методе "getRenderedEjbql()" в классе org.jboss.seam.framework.Query. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный EJBQL код на целевой системе.

URL производителя: labs.jboss.com/jbossseam/

Решение: Установите последнюю версию 2.0.0.GA или выше с сайта производителя.

или введите имя

CAPTCHA