Множественные уязвимости в Falcon Series One

Дата публикации:
11.12.2007
Дата изменения:
31.12.2007
Всего просмотров:
1057
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-6488
CVE-2007-6489
CVE-2007-6490
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Falcon Series One 1.x
Уязвимые версии: Falcon Series One 1.4.3, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "dir[classes]" в сценарии sitemap.xml.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/sitemap.xml.php?dir[classes]=[code]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "gb_mail", "gb_name" и "gb_text" в сценарии index.php (когда параметр "guestbook" установлен в значение "v"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF атаку.

URL производителя: sourceforge.net/projects/falconcms/

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

31.12.2007
Добавлен PoC код.

или введите имя

CAPTCHA