SQL-инъекция в WordPress

Дата публикации:
11.12.2007
Дата изменения:
31.12.2007
Всего просмотров:
2351
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.3.1 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "s" в сценарии index.php, когда параметры "exact" и "sentence" установлены в значение "1". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости злоумышленник должен знать префикс таблиц в базе данных и опция "DB_CHARSET" в сценарии wp-config.php должна быть установлена в "GBK" или "Big5". Пример:

http://[host]/wordpress/index.php?exact=1&sentence=1&s=%b3%27)))[SQL]

URL производителя: wordpress.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA