Обход ограничений безопасности в MySQL

Дата публикации:
10.12.2007
Дата изменения:
13.10.2008
Всего просмотров:
1603
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MySQL 4.x
MySQL 5.x
Уязвимые версии: MySQL версии до 4.1.24 и 5.0.51

Описание:
Уязвимость позволяет локальному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за ошибки во время переименования таблицы с опциями DATA DIRECTORY и INDEX DIRECTORY. Злоумышленник может с помощью специально сформированной символической ссылки перезаписать System Table Information.

URL производителя: www.mysql.com

Решение: Установите последнюю версию 4.1.24 или 5.0.51 с сайта производителя.

Ссылки: http://dev.mysql.com/doc/refman/5.0/en/releasenotes-cs-5-0-51.html
http://dev.mysql.com/doc/refman/4.1/en/news-4-1-24.html

или введите имя

CAPTCHA