PHP-инклюдинг в tellmatic

Дата публикации:
03.12.2007
Дата изменения:
24.03.2009
Всего просмотров:
24010
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-6231
CVE-2007-6232
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
tellmatic 1.x
Уязвимые версии: tellmatic 1.0.7.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "tm_includepath" в сценариях include/Classes.inc.php, include/statistic.inc.php, include/status.inc.php, include/status_top_x.inc.php и include/libchart-1.1/libcharinclude/libchart-1.1/libchart.phpt.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/tellmatic/include/Classes.inc.php?tm_includepath=[file]
http://[host]/tellmatic/include/statistic.inc.php?tm_includepath=[file]
http://[host]/tellmatic/include/status.inc.php?tm_includepath=[file]
http://[host]/tellmatic/include/status_top_x.inc.php?tm_includepath=[file]
http://[host]/tellmatic/include/libchart-1.1/libchart.php?tm_includepath=[file]

URL производителя: tellmatic.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA