SQL-инъекция в Asterisk

Дата публикации:
30.11.2007
Дата изменения:
27.12.2007
Всего просмотров:
1136
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Asterisk 1.x
Asterisk Business Edition 2.x
Уязвимые версии:
Asterisk версии до 1.2.25 и 1.4.15
Asterisk Business Edition версии до B.2.3.4

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в строках ANI и DNIS в механизме журналирования Call Detail Record Postgres. Удаленный пользователь может с помощью специально сформированных строк выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.asterisk.org

Решение: Установите последнюю версию Asterisk 1.2.25, Asterisk 1.4.15, или Asterisk Business Edition B.2.3.4с сайта производителя.

или введите имя

CAPTCHA