PHP-инклюдинг в Charray's CMS

Дата публикации:
29.11.2007
Дата изменения:
27.12.2007
Всего просмотров:
1183
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Charray's CMS 0.x
Уязвимые версии: Charray's CMS 0.9.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ccms_library_path" в сценариях decoder/gallery.php и decoder/markdown.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/decoder/markdown.php?ccms_library_path=[file]
http://[host]/decoder/gallery.php?ccms_library_path=[file]

URL производителя: sourceforge.net/projects/charray-cms/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA