Межсайтовый скриптинг в vBTube

Дата публикации:
28.11.2007
Дата изменения:
24.03.2009
Всего просмотров:
1924
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
vBTube 1.x (модуль к vBulletin)
Уязвимые версии: vBTube (модуль к vBulletin) 1.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "search" в сценарии vBTube.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/vBTube.php?do=search&search=<script>alert(document.cookie)</script>

URL производителя: www.vbulletin.org/forum/showthread.php?t=160150

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:

29.11.2007
Добавлен PoC код.
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA