Уязвимость форматной строки в Ruby-GNOME2

Дата публикации:
28.11.2007
Дата изменения:
02.01.2008
Всего просмотров:
1025
Опасность:
Средняя
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby-GNOME2 0.x
Уязвимые версии: Ruby-GNOME2 0.16.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость форматной строки обнаружена в методе "Gtk::MessageDialog.new()" в файле gtk/src/rbgtkmessagedialog.c. Удаленный пользователь может с помощью специально сформированной строки, переданной уязвимой функции, выполнить произвольный код на целевой системе.

URL производителя: ruby-gnome2.sourceforge.jp

Решение: Установите исправление из SVN репозитория производителя.

или введите имя

CAPTCHA