Раскрытие данных в PHP-Nuke NSN Script

Дата публикации:
28.11.2007
Дата изменения:
30.11.2007
Всего просмотров:
1190
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NSN Script Depository (модуль к PHP-Nuke) 1.x
Уязвимые версии: PHP-Nuke NSN Script 1.0.3 (750_103pl1), возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным на системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "show_file" в сценарии modules.php (когда параметр "name" установлен в значение "Script_Depository" и параметр "op" в значение "show_file"). Удаленный пользователь может указать в запросе абсолютный путь к произвольному файлу на системе и просмотреть его содержимое.

URL производителя: sourceforge.net/projects/nukescripts/

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

30.11.2007
Добавлен PoC код.

Ссылки: PHP-Nuke NSN Script Depository Source Code Information Disclosure Exploit

или введите имя

CAPTCHA