Переполнение буфера в Aurigma Image Uploader ActiveX компоненте

Дата публикации:
24.11.2007
Дата изменения:
24.03.2008
Всего просмотров:
1176
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Aurigma Image Uploader 4.x
Уязвимые версии: Aurigma Image Uploader ActiveX 4.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в Aurigma.ImageUploader.4.1 ActiveX компоненте. Удаленный пользователь может с помощью специально сформированного Web сайта вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.aurigma.com/Products/ImageUploader/

Решение: Установите последнюю версию 4.5.70 с сайта производителя.

Журнал изменений:

30.11.2007
Изменена секция "Решение".

Ссылки: Aurigma Image Uploader ActiveX Buffer Overflow PoC

или введите имя

CAPTCHA