Несколько уязвимостей в PHP Helpdesk

Дата публикации:
20.11.2007
Дата изменения:
10.04.2009
Всего просмотров:
1079
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5915
CVE-2007-5916
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP Helpdesk 0.x
Уязвимые версии:PHP Helpdesk 0.6.16, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести SQL инъекцию и получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "whattodo" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Пример:

http://[host]/index.php?whattodo=../../../../../../../../../../../etc/passwd%00

2. Уязвимость существует из-за недостаточной обработки входных данных на странице входа. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: phphelpdesk.sourceforge.net/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA