Множественные уязвимости в PHP

Дата публикации:
12.11.2007
Всего просмотров:
1896
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 5.2.x
Уязвимые версии: PHP версии до 5.2.5

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за ошибок в функциях "htmlentities" и "htmlspecialchars", когда частичные многобайтовые последовательности символов не принимаются.

2. Уязвимость существует из-за ошибок проверки границ данных в функциях "fnmatch()", "setlocale()" и "glob()". Удаленный пользователь может вызвать переполнение буфера.

3. Уязвимость существует из-за ошибки при обработке ".htaccess" файлов. Злоумышленник может изменить директиву "mail.force_extra_parameters" в ".htaccess" файле и обойти ограничения директивы "disable_functions".

4. Уязвимость существует из-за ошибки при обработке переменных, которая позволяет злоумышленнику с помощью функции "ini_set()" переопределить значения переменных в httpd.conf файле.

URL производителя: www.php.net

Решение: Установите последнюю версию 5.2.5 с сайта производителя.

или введите имя

CAPTCHA
14-11-2007 11:56:57
Н-да... это уже даже и не новость вовсе, а так - еженедельный боянчег... PHP только могила и исправит.
0 |