PHP-инклюдинг в nuBoard

Дата публикации:
08.11.2007
Дата изменения:
10.04.2009
Всего просмотров:
1711
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
nuBoard 0.x
Уязвимые версии: nuBoard 0.5, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "site" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/admin/index.php?site=[file]

URL производителя: switch.dl.sourceforge.net/sourceforge/nuboard/nuboard_v0.5.tar.gz

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.milw0rm.com/exploits/4606

или введите имя

CAPTCHA