Переполнение буфера в SSReader Pdg2 Control ActiveX компоненте

Дата публикации:
07.11.2007
Дата изменения:
27.02.2008
Всего просмотров:
1296
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SSReader 4.x
Уязвимые версии: SSReader 4.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в Pdg2 ActiveX control (pdg2.dll) компоненте при обработке аргументов, передаваемых методу "Register()". Злоумышленник может с помощью специально сформированного Web сайта передать слишком длинный аргумент (более 256 байт) уязвимому методу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

Примечание: уязвимость эксплуатируется в настоящее время.

URL производителя: www.ssreader.com/downland_index.asp

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA