Несколько уязвимостей в IBM Informix Dynamic Server

Дата публикации:
07.11.2007
Дата изменения:
23.11.2007
Всего просмотров:
1033
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5670
CVE-2007-5956
CVE-2007-5957
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM Informix Dynamic Server 9.x
IBM Informix Dynamic Server 10.x
Уязвимые версии: IBM Informix Dynamic Server версии до 10.00.xC7W1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании и повысить свои привилегии на системе.

1. Уязвимость существует из-за неизвестной ошибки при использовании SQ_ONASSIST запроса. Удаленный пользователь может аварийно завершить работу приложения на Windows системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в переменной окружения DBLANG. Локальный пользователь может с помощью символов обхода каталога заставить set-uid приложения использовать Native Language Support (NLS) файлы.

URL производителя: www.ibm.com

Решение: Установите последнюю версию 10.00.xC7W1 с сайта производителя.

Ссылки: iDefense Security Advisory 11.09.07: IBM Informix Dynamic Server DBLANG Directory Traversal Vulnerability
http://www-1.ibm.com/support/docview.wss?uid=swg27011082

или введите имя

CAPTCHA