Уязвимость при обработке HTTP запросов в C++ Sockets Library

Дата публикации:
07.11.2007
Дата изменения:
18.11.2007
Всего просмотров:
1057
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
C++ Sockets Library 2.x
Уязвимые версии: C++ Sockets Library версии до 2.2.5

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки проверки входных данных в файле HTTPSocket.cpp при обработке HTTP запросов. Удаленный пользователь может с помощью специально сформированного HTTP запроса, содержащего пустую строку в версии протокола, аварийно завершить работу приложения, использующего уязвимую версию библиотеки.

URL производителя: www.alhem.net/Sockets/

Решение: Установите последнюю версию 2.2.5 с сайта производителя.

или введите имя

CAPTCHA