Уязвимость при обработке регулярных выражений в Perl

Дата публикации:
06.11.2007
Дата изменения:
13.08.2008
Всего просмотров:
1912
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5116
CVE-2008-1927
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Perl 5.x
Уязвимые версии: Perl 5.8.8, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке регулярных выражений, содержащих данные в кодировке Unicode. Злоумышленник может с помощью специально сформированного регулярного выражения вызвать переполнение буфера и скомпрометировать целевую систему.

URL производителя: www.perl.org

Решение: Установите последнюю версию 5.9.5 с сайта производителя.

или введите имя

CAPTCHA