Переполнение буфера в Novell BorderManager

Дата публикации:
01.11.2007
Всего просмотров:
936
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Novell BorderManager 3.7
Novell BorderManager 3.x
Уязвимые версии: Novell BorderManager 3.8, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за того, что приложение Client Trust (clntrust.exe) некорректно обрабатывает запросы на подтверждение подлинности, отправленные на порт 3024 UDP. Удаленный пользователь может вызвать переполнение динамической памяти с помощью специально сформированного запроса, содержащего дерево имен Novell без обратного слеша или нулевого символа, и выполнить произвольный код на целевой системе.

URL производителя: www.novell.com/products/bordermanager/

Решение: Установите исправление с сайта производителя.
download.novell.com/Download?buildid=AuOWp2Xsvmc~

Ссылки: ZDI-07-064: Novell Client Trust Heap Overflow Vulnerability

или введите имя

CAPTCHA