PHP-инклюдинг в Sige

Дата публикации:
29.10.2007
Всего просмотров:
887
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sige 0.x
Уязвимые версии: Sige 0.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "SYS_PATH" в сценарии inc/sige_init.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/inc/sige_init.php?SYS_PATH=[file]

URL производителя: sourceforge.net/projects/pfadmin

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA