Переполнение буфера в Nagios Plugins

Дата публикации:
26.10.2007
Дата изменения:
20.05.2008
Всего просмотров:
1119
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Nagios Plugins 1.x
Уязвимые версии: Nagios Plugins 1.4.10

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в "check_snmp" плагине при обработке SNMP GET ответов. Удаленный пользователь может с помощью специально сформированного SNMP GET ответа вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/nagiosplug/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA