Межсайтовый скриптинг в Drupal Token

Дата публикации:
20.10.2007
Дата изменения:
24.03.2009
Всего просмотров:
2116
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Token 4.x (модуль к Drupal)
Token 5.x (модуль к Drupal)
Уязвимые версии: Token (модуль к Drupal версии до 4.7.x-1.5 и 5.x-1.9

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в комментариях, названиях словарей, терминах и именах пользователей. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости злоумышленнику требуется валидная учетная запись в приложении.

Следующие модули используют модуль Token и являются уязвимыми к XSS атаке:
ASIN Field Module, e-Commerce Module, Fullname field для CCK Module, Invite Module, Node Relativity Module, Pauthauto Module, PayPal Node Module и Ubercart Module

URL производителя: drupal.org/project/token

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA
25-11-2007 19:04:46
www.eurohackers.net
0 |