Несколько уязвимостей в Drupal

Дата публикации:
19.10.2007
Всего просмотров:
2389
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5593
CVE-2007-5594
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 5.x
Уязвимые версии: Drupal версии до 5.3

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в сценарии install.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе. Для удачной эксплуатации уязвимости требуется, чтобы SQL сервер был недоступен.

2. Уязвимость существует из-за недостаточной проверки валидности HTTP запроса перед выполнением некоторых действий. Удаленный пользователь может с помощью специально сформированного Web сайта произвести CSRF атаку.

URL производителя: drupal.org

Решение: Установите последнюю версию 5.3 с сайта производителя.

или введите имя

CAPTCHA
25-11-2007 19:05:44
www.eurohackers.net
0 |