SQL-инъекция в Asterisk-Addons

Дата публикации:
17.10.2007
Всего просмотров:
1049
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Asterisk-Addons 1.x
Уязвимые версии: Asterisk-Addons версии до 1.2.8 и 1.4.4

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки номеров источника и назначения в модуле "cdr_addon_mysql" перед отправкой запроса базе данных. Удаленный пользователь может внедрить и выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.asterisk.org

Решение: Установите последнюю версию 1.2.8 или 1.4.4с сайта производителя.

Ссылки: Asterisk-Addons remote SQL Injection PoC
AST-2007-023: SQL Injection vulnerability incdr_addon_mysql