Выполнение произвольных команд в HPLIP

Дата публикации:
12.10.2007
Дата изменения:
24.03.2009
Всего просмотров:
1085
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
HPLIP 2.x
Уязвимые версии: HPLIP 2.x

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за того, что демон hpssd недостаточно проверяет некоторые входные данные перед вызовом sendmail с помощью метода "popen3()". Злоумышленник может отправить специально сформированные запрос демону hpssd и выполнить произвольные команды на системе с привилегиями пользователя root.

Примечание: Удаленная эксплуатация уязвимости возможна при определенной конфигурации демона hpssd.

URL производителя: hplip.sourceforge.net/index.html

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: [RHSA-2007:0960-01] Important: hplip security update

или введите имя

CAPTCHA