PHP-инклюдинг в xKiosk WEB

Дата публикации:
09.10.2007
Всего просмотров:
1110
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
xKiosk WEB 3.x
Уязвимые версии: xKiosk WEB 3.0.1i, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "PEARPATH" в сценарии /system/funcs/xkurl.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/system/funcs/xkurl.php?PEARPATH=[file]

URL производителя: xkiosk.net/?p=default&pr=xkiosk_web

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA