Межсайтовый скриптинг в GForge

Дата публикации:
04.10.2007
Дата изменения:
11.01.2009
Всего просмотров:
875
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GForge 4.x
Уязвимые версии: GForge 4.6b2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "confirm_hash" в сценарии account/verify.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: gforge.org

Решение: Установите исправление из SVN репозитория производителя.

Ссылки: http://gforge.org/tracker/?func=detail&atid=105&aid=3094&group_id=1

или введите имя

CAPTCHA